Special Service Mustang.net Forums

Go Back   Special Service Mustang.net Forums > Special Service Mustang Tech
Register FAQ Members List Calendar Mark Forums Read

Special Service Mustang Tech Any and all technical questions for SSP cars.

Reply
 
Thread Tools Display Modes
  #11  
Old 05-07-2018, 07:07 PM
JerryPHX JerryPHX is offline
Retired L.E.O.
 
Join Date: Oct 2014
Location: Arizona
Posts: 65
Default Here's the prices for an ECM at Oreilly's Auto parts

Hope this shows up.
Attached Images
File Type: jpg ECM.jpg (26.1 KB, 26 views)
Reply With Quote
  #12  
Old 05-08-2018, 10:54 AM
meders meders is offline
Member
 
Join Date: Apr 2016
Location: asheville, north carolina
Posts: 46
Default

yeah it shows up but when you add it to your cart it says 0 quantity available. i also went by o'reillys the other night with the stock number and they don't have it in their computer.

i am going by a tuner shop nearby today to ask about the reflashing then i am going to look into the fuse links. since they would have gotten wet with the rinsing of the engine.

one other thing that i noticed after the car died on me and limped it home was that the hose from the intake to the charcoal canister was not attached. i don't know how long it had been that way. it could have been that way since i bought it. but it ran perfectly 16 months.
Reply With Quote
  #13  
Old 05-08-2018, 11:15 AM
JerryPHX JerryPHX is offline
Retired L.E.O.
 
Join Date: Oct 2014
Location: Arizona
Posts: 65
Default Good luck....

Good luck with the ECM.
I don't remember the canister hoses routing but I would reattach it.
I'm surprised the little yellow "check engine" light on the dash wasn't on. When it does light it's a Emission problem.
Also, something I remembered last night. On my present car, if the Battery isn't totally 100% (getting old) it starts "throwing codes" on the instrument panel and door modules, seat modules and interior lights all go crazy. I also know that if the ECM isn't receiving a full 12 volts, it will shut down. So, possibly with your car shutting down after 10 minutes of running it maybe trying to tell you something.
So, How's the battery and alternator?

Let us know what happens,
Jerry

Last edited by JerryPHX; 05-08-2018 at 11:18 AM. Reason: misspell
Reply With Quote
  #14  
Old 05-15-2018, 10:23 PM
meders meders is offline
Member
 
Join Date: Apr 2016
Location: asheville, north carolina
Posts: 46
Default

well i had to but this on the back burner for the time being. my daily driver toyota truck needed some repairs. idler arm broke and driver side tire was wearing on the inside down to almost threads. got that fixed today and tomorrow get the 26 year old busted shocks replaced.

the battery is getting some age and not sure about alternator but once the weather gets better, next 4 days don't look good, those will be looked into.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:19 AM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.